Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Speedo not working

  1. #1

    Speedo not working

    Hi guys my speedo isn't working on my 1.8t AGU. The car was a 9a before with electronic speed sensor not the cable type. I've plugged in the gearbox connector and tried 2 different sensors and still nothing. Am I missing something? I've got code P0501/16885 and did have 00515 camshaft sensor but that has cleared and not come back.

  2. #2
    ⋆⋆ CF Donator ⋆⋆
    Join Date
    19th January 2006
    Location
    South Manchester + Hazel Grove
    Posts
    108
    Have you tried the suggestions regarding the retrieved code?
    http://wiki.ross-tech.com/wiki/index...5/P0501/001281

  3. #3
    Well I don't know exactly where the other end of the wire goes to, ECU? In which case there's no way it's not plugged in. And I'm under the impression the ABS wheel sensor is irrelevant? The ECU gets its speed from the gearbox right?

  4. #4
    Can anyone help me with this?

    I've narrowed it down to the VSS plug not giving me 12v ignition live. 5v signal works and ground has continuity. Does anyone know where the 12v comes from (G22)?

  5. #5
    CF Nutter rado20vT's Avatar
    Join Date
    4th November 2005
    Location
    In my garage, somewhere near the top of Suffolk
    Posts
    1,150
    The 12v comes from the ignition live feed, benley shows the same feed as the ECM IGN live, its a black wire that comes from G1/4 of the fuse box (thick wire from fuse then spliced to a smaller black wire)

    For my 1.8T conversion, the signal to the gearbox sensor went direct to the cluster to drive the speedo and didnt go to the engine ECU.

    This time I have wired it so the signal T's off and also runs to the ECU (but its not running yet).
    Graham
    20v Turbo, Audi TT Leather, 17" BBS, 330mm front discs with Brembo;s, 256mm rear, Digital dash in development
    OEM++

  6. #6
    I'll check G1/4 then thanks. It's a white/black wire from the connector so does it go to ECU and then to fusebox as a solid black? I hate auto electronics

  7. #7
    G1/4 is wired to the clutch switch which I don't even have. I've figured out it's wired for a mk4 so it goes from pin 1 on the vss BLK/WHT to t14a/2 BLK/GRN and then from there I can't find a diagram to help me locate. All I've got is it goes to b163?

  8. #8
    ⋆⋆ CF Donator ⋆⋆
    Join Date
    19th January 2006
    Location
    South Manchester + Hazel Grove
    Posts
    108
    There is a chap named rubjonny - a moderator on the Club GTi forum - who has accrued many useful documents: have a rummage:
    https://drive.google.com/drive/folde...0NWM2?hl=en_GB

    Look for something like g3vr6ecu95on.pdf - keep scrolling down, and more items are listed.

  9. #9
    I've already been through rubjonny's repository and I've basically now realised whoever has done the loom has put the 12v feed absolutely anywhere and I don't think I'll find it. Regardless I'm not getting 12v. I'll check my fuses and then I'll run a new 12v. Any recommendations on the best place for ignition live? The closer to the gearbox the better I guess

  10. #10
    It does say it goes up positive connection 1 (15), in interior wiring harness. But I have no idea where and what this is

Similar Threads

  1. Speedo not working ????
    By LowDownLuke in forum Interior
    Replies: 9
    Last Post: 12th March 2010, 8:13 PM
  2. Speedo not working
    By hodgkinsons in forum Interior
    Replies: 5
    Last Post: 21st November 2006, 10:20 PM
  3. Speedo not working
    By huskerjim in forum Interior
    Replies: 2
    Last Post: 20th April 2006, 11:42 PM
  4. speedo not working
    By vr6storm in forum Archive
    Replies: 3
    Last Post: 31st August 2004, 11:08 AM
  5. speedo not working
    By boab in forum Archive
    Replies: 3
    Last Post: 15th August 2004, 9:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
We are the world's largest community for VW's Super Coupé! Be it 8v, 16v, G60 or VR6 (or maybe something else!), everybody's welcome! If this is your first visit, be sure to click register and fill out your details before you can post.
Help us
This site is run on donations.
Please help keep the forum alive!
Follow us
advertising & sponsorship
Are you a company looking for advertising that could benefits our users? For site & forum sponsorship, please see our dedicated microsite here.