Results 1 to 4 of 4

Thread: High revs when cold

  1. #1
    Newbie
    Join Date
    7th December 2014
    Posts
    43
    Blog Entries
    1

    High revs when cold

    Hi all, had my G60 on the road for a month now after servicing the charger and doin numerous other bits. But the past couple of weeks the throttle has been sticking, anywhere between 1500 and 5000 rpm! This only happens when it's cold, as soon as its warmed up its fine, but it's very annoying!

    I've checked the cable, that's good. I've removed the ISV and that's free. What is the next thing I should check? the only mod I've got is a 68mm pulley and chip from Ocd, but I'm pretty sure it's not this as it was fine for a couple of weeks.

    Any pointers would be much appreciated.

  2. #2
    Enthusiast Ray1965's Avatar
    Join Date
    5th February 2013
    Location
    South Yorkshire
    Posts
    879
    Don't know if this will shed any light on the problem.

    http://the-corrado.net/showthread.php?t=32650
    Daily Drive 1995 BLACK VR6 Vee Reihenmotor. Headlight loom upgrade. Magnex Exhaust.

    http://the-corrado.net/showthread.ph...hlight=Ray1965

  3. #3
    Newbie
    Join Date
    7th December 2014
    Posts
    43
    Blog Entries
    1
    Thanks Ray1965. I will defo try this. I had another fiddle last night and found the throttle cable was a little sluggish returning. I disconnected it and the throttle body spring back no problem. Does anyone know where you can get a throttle cable from if I need one or can you service them? The thing I don't get is it's fine when the engines warm???

  4. #4
    Enthusiast Ray1965's Avatar
    Join Date
    5th February 2013
    Location
    South Yorkshire
    Posts
    879
    No worries, The cable does sound as if it is in need of some lubrication. As for the problem it's self i don't think it is cable related.
    You could try contacting VW Heritage for a new cable.
    https://www.vwheritage.com
    Daily Drive 1995 BLACK VR6 Vee Reihenmotor. Headlight loom upgrade. Magnex Exhaust.

    http://the-corrado.net/showthread.ph...hlight=Ray1965

Similar Threads

  1. VR high revs on cold morning start
    By georgek in forum Engine Bay
    Replies: 16
    Last Post: 12th November 2006, 11:49 AM
  2. revs too high
    By maximus2029 in forum Engine Bay
    Replies: 1
    Last Post: 21st February 2005, 11:06 AM
  3. revs too high on start
    By maximus2029 in forum Engine Bay
    Replies: 2
    Last Post: 20th February 2005, 8:41 PM
  4. Revs too high and stays high........
    By maximus2029 in forum Engine Bay
    Replies: 4
    Last Post: 21st December 2004, 2:41 PM
  5. g60 revs high on first start up
    By brian g60 corrado in forum Engine Bay
    Replies: 2
    Last Post: 7th July 2003, 4:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
We are the world's largest community for VW's Super Coupé! Be it 8v, 16v, G60 or VR6 (or maybe something else!), everybody's welcome! If this is your first visit, be sure to click register and fill out your details before you can post.
Help us
This site is run on donations.
Please help keep the forum alive!
Follow us
advertising & sponsorship
Are you a company looking for advertising that could benefits our users? For site & forum sponsorship, please see our dedicated microsite here.