Jump to content
Sign in to follow this  
skid

Rev counter and LCD displays not working right?

Recommended Posts

After 8 years of sitting not getting used I am in the process of getting my G60 running again.

After first fewstart ups I noticed my LCD panels on the dash were not working initially but and partially lite up but not showing figures/digits correctly yet.

Also the rev counter only now flickers off the stop pin and shows no Revs?

 

Anything worth checking, all help appreciated 🙏 

Share this post


Link to post
Share on other sites
Posted (edited)

Check the connection to the clocks, 8V MK2 Golf had an earth to the clocks on the corner of the engine cam cover, might be worth  a look there?

Edited by Dox

Share this post


Link to post
Share on other sites

if you open the clocks, check the flexible conductive rubber strips to the LCDs are properly in place.  If not, you'll get the symptoms you're experiencing..

The look like flat pieces of rubber and are either side of the lcd display

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...