Jump to content
STORM 2

Window Motor & Regulator.

Recommended Posts

Looking for the driver's side Window Motor & Regulator.

Driver’s window seems to work sometimes and decides not to at other times ?

 

Share this post


Link to post
Share on other sites
2 hours ago, STORM 2 said:

Looking for the driver's side Window Motor & Regulator.

Driver’s window seems to work sometimes and decides not to at other times ?

 

Are you sure the switch on the door card and plug on the motor end are good. 

Share this post


Link to post
Share on other sites

Agreed. That tends to be the culprit. When you open the switch and clean it, fill it, and the socket pins with silicone grease. Stops oxygen accessing the contact, prevents it happening again.  

Share this post


Link to post
Share on other sites

Relatively easy to test the motor by unplugging the loom and hooking up a small leisure battery to drive it - just reverse +/-  to go in the other direction.  Once the door card is off it will be easy to see what's what.

The switch is also often the culprit, and there are some relays behind the RHS rear seat trim, but more often than not the motors just give up and start seizing - some have had some success by giving the motor housing a few sharp taps to free it up, and I've seen some DIYs on opening up and refurbishing the motors, but that may be overkill.

Second hand motors will also be tired.

If your window guide rails and the channels that the rollers sit in at the bottom are dirty or damaged, this can cause the motor to cut out before it pulls too much current.

Share this post


Link to post
Share on other sites

Thanks for the replies guys.

I’ve tried cleaning out the switch. - looked pristine inside anyway TBH. I can hear the relay switching behind the rear door card but no action at the window.

I tried plugging in the passenger side switch into the drivers side, again relay clicks but no action..

do you think i need to look at the motor ?

Share this post


Link to post
Share on other sites
5 minutes ago, STORM 2 said:

Thanks for the replies guys.

I’ve tried cleaning out the switch. - looked pristine inside anyway TBH. I can hear the relay switching behind the rear door card but no action at the window.

I tried plugging in the passenger side switch into the drivers side, again relay clicks but no action..

do you think i need to look at the motor ?

Yes. Door card off time... unplug the motor and test that you have voltage at this plug when using the switch. Rules out everything up to the motor. Then look to see if it is stuck. It's amazing what a clean and some silicone can do in the tracks and runners Hopefully it is that simple !!

Share this post


Link to post
Share on other sites

i have the same issue - pass side clicks but doesnt move.  I've stripped and relubed the driver side motor before which was a hassle but hopefully it wont come to that here...

Share this post


Link to post
Share on other sites

The motor will have a 12v feed, then 12v to the relay you hear clicking from the switch. It could be the motor or the feed to the door has broken between the shell and the door 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...