Jump to content
easypops

My VR6 and Storm

Recommended Posts

Picked up this today from Joe M,.......cheers Joe(really nice guy,easy to deal with)

Twilight Violet,koni coilovers,Eibach arb, vibratech engine mounts......the brakes need done and the bodywork needs a little tlc but its not that bad.........i'm very happy with it......great drive home :D :clap:

 

Looks like there will be a valver for sale soon :norty:

Edited by easypops

Share this post


Link to post
Share on other sites

Looks like a good blank canvas for a lot of work !.......................good luck............ :D

Share this post


Link to post
Share on other sites
Glad you enjoyed the drive home, did you put the foot down at all? :norty:

 

Lets say i understand now :clap: :dance:

 

Thanks again Joe :salute:

 

Edit: Nice new avatar mate 0X

Share this post


Link to post
Share on other sites

Good to see the car stay on here... The spec sounds great. I'd be well chuffed to be able to buy a car with all of that already done to it. :)

Share this post


Link to post
Share on other sites

I am delighted :D .....there is probably more done than i listed.....looking at the pile of receipts this c has wanted for very little over its life.......just needs the brakes and bodywork sorted and it'll be a minter :clap:

Share this post


Link to post
Share on other sites

During the week past i had the factory alarm/immobiliser and the clifford immobiliser removed to be replaced with a trusty TOAD AI606........It was cutting out if i hit a pothole so i blamed the immobilisers(after a search and advise from the gurus) :shrug: ........not cut out since though so i/they must have been correct :lol:

Share this post


Link to post
Share on other sites

Also got round to swapping the rear lights......still not liking the inpros, now on the 16v........will be swapping for some standard ones before i sell it.....then i'll be selling the inpros too :D .......also changed the side repeaters to dark smoked and fixed the drivers door window(popping out ).......fitted the new tweeter(Thanks Joe).....and fitted a new cd player.....oh and washed it too :lol:

Share this post


Link to post
Share on other sites

Took the seats out and gave them a clean and used some leather feeder on them......also touched up the worn bit on the drivers seat.....hoovered the inside and gave it all a wee spruce up :D

Share this post


Link to post
Share on other sites
Nice :D

 

What did you use on the driver's seat bolster? Looks really good

 

Grey shoe polish :lol:

Share this post


Link to post
Share on other sites
Nice :D

 

What did you use on the driver's seat bolster? Looks really good

 

Grey shoe polish :lol:

 

ha ha i wondered the same thing, very clever m8......tho not good with white t-shirts i imagine :p

Share this post


Link to post
Share on other sites
Lookin good, did you remember to plug the heated seats back in unlike myself? lol

 

I only planned on taking the drivers seat out to put the plug back in but its such an easy job i decided to get all the seats out :D .....and yes i did remember to plug them in Joe 8) :clap:

Share this post


Link to post
Share on other sites

nice work, with all these lovely vr's about am questionning my own plans :scratch:

 

couldn't help but notice you may be seeling ur valver... please let me know if so - am serious :D

Share this post


Link to post
Share on other sites
nice work, with all these lovely vr's about am questionning my own plans :scratch:

 

couldn't help but notice you may be seeling ur valver... please let me know if so - am serious :D

 

Cheers mate.....and yes the valver is up for sale.....as you'll see in the ad i've been as honest as possible........spent a lot on it over the years but it needs a little tlc now

 

viewtopic.php?f=12&t=81495

 

Oh and from tomorrow morning i wont be on here for about 5 days.....walking the West highland Way :cuckoo: :lol:

Share this post


Link to post
Share on other sites

ahh sorry man from the pics i thought it was an early bonnet i.e the 1.8, good luck with the sale anyway it's nice and would look ace with a bit of undivided tlc :D

Share this post


Link to post
Share on other sites

Thought i better update this as not done so for ages.......since the last update i have needed to have a few things done

Full set of discs and pads all round, New clutch, clutch release fork.

That was it for a wee while, then noticed an oil leak at the front.......turned out to be the oil pressure switch, that easy a job i did it myself :lol:

Then the exhaust started blowing :p ......it was a Stainless Steel cat back system which had been fitted almost 5years ago by C&C Custom Exhausts in Hillington, Glasgow......which is only 10 mins drive from me, so i went there armed with the receipt (Thanks again Joe) to see what they would say, and i have to say what nice helpful guys they were, not only were they happy to sort it, they basically renewed the lot barring the back box, all for no charge.......lifetime guarantee indeed :clap: :notworthy:

Still to get the bodywork issues fixed, but that'll get done eventually.........with the 'new' exhaust it now starts , idles and revs better........and it wasn't that bad before :D

Also fitted the Gunsmoke Light tints bought from Riley(cheers mate)

Share this post


Link to post
Share on other sites

Not updated this for a wee while so thought i should........Have had an annoying oil leak which seemed to be coming from between the gearbox and the block, feared it was the crankshaft oil seal.........also had a bad noise coming from the water pump area. I was busy getting the parts ready to sort these bits out and a few other bits while i have the front end off, and last monday(the day i was meant to be driving to oban with the gang doing the scottish tour) while at the shops i started it up and there was a real bad noise, followed by a bang and a puff of smoke from the drivers side front :shock: .........power steering felt bad and the battery light came on........i thought the water pump had exploded but it was the belt tensioner which had dissolved slightly :lol:

Anyway as i could no longer drive it i cleared out the garage and rolled the car in for some surgery :D

Share this post


Link to post
Share on other sites

After removing the stone guard/ flywheel cover and having a good look at whats happening i decided that its not the crankshaft oil seal which is leaking.........must be the sump gasket, and the oil cooler looks to be weaping slightly too, so its off with that also........and i have a new filter in a nice clean housing ready to go on too so that should hopefully sort out the oil leak......just need to get all the gaskets and a selection of screws and bolts as i'm not putting any of the old rusty ones back on :lol:

 

I have a replacement vr6 sump gasket but its not the same as the one i removed.........can anyone shed some light on this.......are there 2 types?......it looks the same shape but is made of cork or similar and the old one seems to be metal and rubber?????

Share this post


Link to post
Share on other sites

Busy busy, as long as the sump gaskets the same shape which it looks to be, it should be fine. Just make sure the surface is properly clean before fitting. Also check if the sump is warped or anything before fitting, I know it had scraped the deck a few times... I might have a spare in my shed you can have if it is damaged.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...