Jump to content
easypops

My VR6 and Storm

Recommended Posts

2 hours ago, easypops said:

No mate, the gearbox came in the fire damaged car that Michael and myself bought a couple of years back, Michael took the head and the VSR, I retained the rest, the gearbox had an issue the previous owner made us aware of, 1st and 2nd difficult to select. I took it to a gearbox mechanic that I know through a friend, he repaired it and changed the 5th gear, I supplied the 5th but as I’d only ordered one half of it he supplied one 😁👍

I did ask if he could swap the lsd(wavetrac) into my working box but he said it would be better/cheaper to fix the box with it already in 

Thanks mate, makes sense. Can't believe how lucky you got with that fire damaged one, absolute bargain with the options it had. 👍

Share this post


Link to post
Share on other sites

Very nice progress indeed! I understand your "stress" after doing so many changes, I feel the same way. You know, if you've done all of this work so far, I don't see why you couldn't figure out the issue if one present itself... Everything will get sorted out one by one. That fire damaged car sure is a real treasure, good for you! I too will be modifying my gearbox with a Wavetrac. I also sourced a R&P 3.94 and a 5th from a diesel, should make a nice combo. Keep up the good work! Cheers

Share this post


Link to post
Share on other sites

Thanks mate, I got another few wee bits done this evening. Ecu fitted, Schrick controller wired up and vacuum pipes sorted, also thought I’d best clean the windscreen and fit a set of Lupo wipers 😁

CFA32305-3829-44A7-AD3A-4D7120576A48.jpeg

Share this post


Link to post
Share on other sites

Oh nice and so did I! I bought the last 2  Audi wiper arms in NA a few weeks ago! Not installed yet though. What size wipers did you ended up buying? I got both in 19". It looks really good on your car, can't wait to install them now! Did you keep your original caps? One of mine is cracked and the new ones are not totally the same. I've read you need to remove a washer or something? Anyway, looks really nice! Modernized oem looking. 

Share this post


Link to post
Share on other sites

I’m tipping he had OE Corrado one knocking around in one of numerous full box’s of new parts. 😂

Share this post


Link to post
Share on other sites
33 minutes ago, 1xshaunx1 said:

I’m tipping he had OE Corrado one knocking around in one of numerous full box’s of new parts. 😂

I’ve heard Heritage Obsolete Parts Dept have him on speed dial 

Share this post


Link to post
Share on other sites
5 hours ago, Dox said:

I’ve heard Heritage Obsolete Parts Dept have him on speed dial 

Classic parts ohone number and his are the same 😂 I'm only jealous mate , as the car is looking awesome

Share this post


Link to post
Share on other sites

Ha ha, that made me laugh 🤣

It does happen to be a genuine Corrado reservoir 😎😁 I’d love to say where/when from but it was just there, I get the feeling it came with the last parts car but not sure 🤔

Share this post


Link to post
Share on other sites

With my reservoir, I ended up brushing it with that creamy product hair dresser uses to color hair, it's 40% volume. You brush that on, wrap it in plastic wrap and leave it in the sun all day. It's not like new but it got 50% whiter I'll say. I'll do it again to see how white it gets... Just putting it out there as it seems there's an interest and we are not all lucky like Martin and have a new one in a box from somewhere. lol. Cheers! 

Share this post


Link to post
Share on other sites

So, great bit of progress tonight, got the brakes bled(they’ll need done again) plus the power steering bled, but most importantly, the engine is alive, idle is a bit high, MAF seems faulty as no difference when unplugged, ill swap it out soon, couple of other gremlins but I’m absolutely delighted that it runs. OBD2 conversion seems to be successful........Teves20 is yet to be confirmed but hopefully I’ll know about it once I get rolling 😁

Share this post


Link to post
Share on other sites
10 hours ago, easypops said:

So, great bit of progress tonight, got the brakes bled(they’ll need done again) plus the power steering bled, but most importantly, the engine is alive, idle is a bit high, MAF seems faulty as no difference when unplugged, ill swap it out soon, couple of other gremlins but I’m absolutely delighted that it runs. OBD2 conversion seems to be successful........Teves20 is yet to be confirmed but hopefully I’ll know about it once I get rolling 😁

Well done that man.
Vince says that signal from maf isn’t used until the engine gets to around 75-80 degrees. It’s using cold start map. So if it’s playing up and makes no difference unplugging the maf at that temp, I’d try a new one too. 

Share this post


Link to post
Share on other sites

Glad to hear it’s up and running, it’s always nervy when you’ve carried out so much modification work, I know OBD2 and Teves20 are both well trodden paths but they’re still fairly major tasks.

Looking forward to seeing the next steps!

Share this post


Link to post
Share on other sites
3 hours ago, 1xshaunx1 said:

Well done that man.
Vince says that signal from maf isn’t used until the engine gets to around 75-80 degrees. It’s using cold start map. So if it’s playing up and makes no difference unplugging the maf at that temp, I’d try a new one too. 

Thanks mate, great information that, I’ll hold off changing the MAF until I’m sure it’s up to temperature. I do have a few spares so it won’t be an issue to check 😁👍

Share this post


Link to post
Share on other sites
2 hours ago, tonedef said:

Glad to hear it’s up and running, it’s always nervy when you’ve carried out so much modification work, I know OBD2 and Teves20 are both well trodden paths but they’re still fairly major tasks.

Looking forward to seeing the next steps!

Thank you mate, you helped me massively with some great information and pictures, so I’m in your debt for sure. On first run of the engine the abs light has stayed on, however I remember you said I’d need to disable the airbag bulb in the switch, although again I’ll hold off until I can scan it, plus I’d like to get the wheels turning before I can be sure it’s getting a signal from each corner 😁👍

Share this post


Link to post
Share on other sites
7 hours ago, Cressa said:

Great progress having a start up. Well done mate

Thanks mate, I was rather nervous 🤣

Share this post


Link to post
Share on other sites
3 hours ago, easypops said:

Thanks mate, I was rather nervous 🤣

Need to get her out now before winter arrives and have a good blast 👍

Share this post


Link to post
Share on other sites
1 minute ago, Keyo said:

Need to get her out now before winter arrives and have a good blast 👍

Absolutely mate 👍😁

Share this post


Link to post
Share on other sites
17 hours ago, easypops said:

Thank you mate, you helped me massively with some great information and pictures, so I’m in your debt for sure. On first run of the engine the abs light has stayed on, however I remember you said I’d need to disable the airbag bulb in the switch, although again I’ll hold off until I can scan it, plus I’d like to get the wheels turning before I can be sure it’s getting a signal from each corner 😁👍

You're very welcome, shame I don't always know my 5 from my 8 eh???

Check if one or both lamps are lit, mine lights up on the right side at start up/ABS check. The left lamp for the airbag warning was permanently lit until I snipped it off the PCB...that fixed it!

 

 

IMG_3590.jpeg

IMG_3589.jpeg

Share this post


Link to post
Share on other sites

What an amazing turn around mate! Very happy for you. It's a huge accomplishment and now it's just a matter of adjusting a few things and you get to enjoy it. Cheers 

Share this post


Link to post
Share on other sites

Tried a wee test fit of the fibreglass wings, they will need a little fettling but not much, I’ll need to clear the chassis of the old sealant used to bond the original wings in I think but it’s difficult when you can’t get the doors open properly........looks like I’ll need to get it out of the garage 😁

BEE0E586-79CD-4B8D-BAAA-B3970553E6E5.jpeg

Share this post


Link to post
Share on other sites

They look good from where i'm sitting the line comes through spot on from the door . Help with nose heavy VR as well .  

Share this post


Link to post
Share on other sites
29 minutes ago, Keyo said:

They look good from where i'm sitting the line comes through spot on from the door . Help with nose heavy VR as well .  

The wings don't weigh a huge amount in fairness. Bonnet, tailgate and doors on the other hand! 😳

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...